On RaspberryPiOS, rbenv looks new(1.1.1). However, ruby-build is very old(2017xxxx). It can be replaced using the following commands.

$ sudo apt uninstall ruby-build
$ mkdir -p "$(rbenv root)"/plugins
$ git clone https://github.com/rbenv/ruby-build.git "$(rbenv root)"/plugins/ruby-build